В Кали Линукс нет звука .

24.06.2016 17 Автор GodKnowses

В Кали Линукс нет звука .

Всем привет, продолжаем разбираться с проблемами в Кали Линукс, и после очередного обновления столкнулся с интересной проблемкой. Ну, не проблема , конечно. Пропал звук, вобщем. И как на почту и в блог пишут люди, я такой не один. Давайте разберёмся вместе.

Статья дополнена по просьбе читателей: исправляем отсутствие звука в разъёме наушников. Если вы не нашли значка громкости в учётной записи root — вам в статью В Кали нет значка громкости.



Симптомы.

  • В Кали Линукс нет звука . Ни при загрузке, ни при воспроизведении музыкальных и видеороликов.

А раньше почему-то был… И ничего не предпринималось ведь…

У меня стоит 64-х битная версия Кали 2.0, но, думаю, прокатит и в остальных версиях. Пару простых команд — и мы в седле.

Сначала проверим, не делась ли куда звуковая карта. Наберём в терминале запрос на вывод имеющихся устройств:

lspci

Кто забыл английский, напомню, что аудиоустройство так и называется — audio. То есть вот оно, родимое:

список устройств кали линуксНужное я выделил. Ну что, уже легче. Проверим, не слетела ли сама аудиослужба. Но чтобы время не тратить, сразу наберите в терминале команду:

apt-get install libasound2 alsa-utils alsa-oss

установка аудио кали линукс



Мой терминал ответил, что всё на месте. А раз так, запустим AlsaMixer и проверим настройки устройств воспроизведения и записи звука:

alsamixer

Ну точно… Всё приглушено… Видите спаренные ММ внизу каждого из устройств?

в кали линукс нет звука

Через F6 выберу карту, выделенную терминалом:

звуковая карта по умолчанию

А теперь с помощью стрелок вправо-влево и клавиши М (латинской, конечно) я снимаю атрибут «mutedприглушён«. Клавиши вверх-вниз увеличат-уменьшат звук. У меня получилось так:

пропал звук кали линукс

Вуаля. Всё работает, мир снова полон красок и, конечно, звуков. Ну не в тишине же наказывать недобросовестных владельцев блогов и сайтов.

В Кали Линукс нет звука: не работают наушники

После обращения одного из пользователей обнаружил, что у меня звука через AUX разъём тоже нет. Тогда приступаем к исправлению. Вынимаем наушники из линейного входа. В терминале записываем команды — найдём файлы конфигурации аудио:

cd /usr/share/pulseaudio/alsa-mixer/paths/
cp analog-output-headphones.conf analog-output-headphones.bak

И изучаем файл конфигурации:

nano analog-output-headphones.conf

нет звука в наушниках в кали

Мне осталось только сменить значение off на on:

звук в наушниках кали линукс

Сохраняю изменения в документе через CTRL + O и перезагружаю Кали. По необходимости можно исправить значение volume = off на volume = ignore. Всё.

Хоть кому-то помог? Успехов нам всем.